DutchIS - nl-mpl-01 Outage – Incident details

All systems operational

nl-mpl-01 Outage

Resolved
Major outage
Started about 5 years agoLasted 33 minutes
Updates
  • Resolved
    UTC
    Resolved

    We just resolved the issue! Your server could be turned off, please check this in the game panel. We're sorry for any inconvenience that this may have created.

  • Investigating
    UTC
    Investigating

    nl-mpl-01 has crashed we are currently investigating this incident.